パスワードを忘れた? アカウント作成
16704100 story
Android

Google Play 開発者サービス、Android 4.4 KitKat のサポート終了へ 13

ストーリー by nagazou
終了 部門より
headless 曰く、

Google は 24 日、Google Play 開発者サービスで Android 4.4 KitKat (API 19・20、KK) へのアップデートを 8 月以降提供しないと発表した (Android Developers Blog の記事Neowin の記事9to5Google の記事)。

Google は Google Play 開発者サービスで KK のサポートを終了する理由として、KK はリリースから 10 年近く経過しており、以降 Android に導入された革新的な改善や機能を利用できないこと、より多くのユーザーが最新の Android へ移行したため 2023 年 7 月時点でアクティブな KK デバイスは 1% 未満となっていることを挙げている。Android Studio で新規プロジェクト作成時に参照できる Android バージョン分布 (5 月 30 日更新) によれば、KK のシェアは 0.5% となっている。KK デバイスは Google Play 開発者サービスのバージョン 23.39.99 以降が提供されなくなるとのこと。

Google 内部での Android 4.4 のコードネームは Key Lime Pie。Androidではそれまでコードネームがそのままメジャーバージョンの名称となっていたが、KitKat は正式リリース時にコードネームと異なる名称が発表された初のバージョンだった。以降、リリース時の名称発表は Android 9 Pie まで続いたが、Android 10 で廃止。それでもコードネームにアルファベット順のデザートの名前を付ける伝統は続いており、Android 12 以降再びコードネーム前面に出されるようになっている。

この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。
  • by Anonymous Coward on 2023年07月27日 8時16分 (#4501355)

    なんかあったっけ?
    マテリアルデザイン?
    https://www.android.com/intl/j... [android.com]

    • by Anonymous Coward

      KitKatはファイラーを有料にするという画期的進化を果たしたバージョンですね

    • by Anonymous Coward

      「Ok Google」に対応したのが4.4から。
      4.4は4.3と見た目ほとんど変わらないけど、中身はほぼ5.0になってる。

      コードネームがリリース時に変わったのは単にKitKatとコラボしたから。
      さすがに開発呼称といえども無許可で登録商標は使わなかった。

  • by Anonymous Coward on 2023年07月27日 8時18分 (#4501357)

    4.4がサポート終了ってことはそれ以前は切られていたの?
    風呂用スマホで4.2一つ使ってるけど、特に問題なくストアも動いていたような。
    Perfect ViewerとVLCあたりが動けば十分使えるが。

    Androidってセキュリティ修正は2~3年で切られるけど、実質使える期間は結構長いよね。

    • by Anonymous Coward

      だよね。
      うちは4.2のタブレット動くよ。アプリはアベマだけ入れてアニメ見ている。
      むしろ筐体が加水分解で劣化している方がきつい。NECよ、何でこんな作りにした。

    • by Anonymous Coward

      Androidってセキュリティ修正は2~3年で切られるけど、実質使える期間は結構長いよね。

      その認識でいいなら別にWindows XPだってまだ使えることになるね

      • by Anonymous Coward

        今どきのソフトはXPで起動できんやろ

        • by Anonymous Coward

          今どきのソフトならAndroid v4系でも動かないよ

    • by Anonymous Coward

      「これからはアプリ開発に対する最低限のサポートもしない」ってだけの話で、これまでにリリースされた古いバージョンのアプリは当然動くよ
      Google Playストア的にも、即座に古いバージョンを使えなくする動機はないしね、動作保証はやらないだろうが
      とはいえ、いずれは内部使用のAPIやプロトコルのバージョンが変わったりで、サービス側から排除されることになるもの

    • by Anonymous Coward

      > 風呂用スマホ
      Android Froyoの隠語かと思った

    • by Anonymous Coward

      今後のバージョンアップで4.4以下がサポートされることはありません、という事です。

      ストアに4.2でアクセスしたら、4.2をサポートしていた頃の古いソフトだけが表示されインストール出来ます。

      具体的に言うと、アプリごとにサポートしているAPIレベルの最小値と最大値が設定されていて、
      APIレベル17(4.2)以下をサポートしてるアプリだけが表示されます。

      これが今後リリースするアプリは、APIレベルの最低値が21(5.0)以上が必須になりますので、
      4.4以下はバージョンアップで切り捨てられることになります。

      • by Anonymous Coward

        それは普通でしょ。
        Google Play 開発者サービスってことは、単純に脆弱性修正もされないからGoogleアカウントと紐付けて使うのは危うくて、API変更にも追従しないからその内使えなくなるって話じゃないの?

typodupeerror

人生unstable -- あるハッカー

読み込み中...